Initially there was no mechanism for determining whether a route is up or down on the Cisco ASA security appliance. And routes will stay in routing table even if the link is down. But with Cisco ASA software version 7.2(1) track availability and installing backup routes was added.
In above diagram, two different ISPs, ISP_A and ISP_B respectively are used for failover purposes. And Cisco ASA is configured in such a way that if ISA_A fails ASA will immediately divert all traffic to ISP_B.
Basically, we configure SLA to keep tracking one particular IP in our case 150.1.2.2 in ISP_A and if SLA tracking couldn’t reach this at any point of time it start diverting all traffic to ISP_B.
!
!
hostname ASA1
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 136.1.0.12 255.255.255.0
!
interface Ethernet0/1
nameif inside
security-level 100
ip address 136.1.121.12 255.255.255.0
!
!
!
hostname ASA1
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 136.1.0.12 255.255.255.0
!
interface Ethernet0/1
nameif inside
security-level 100
ip address 136.1.121.12 255.255.255.0
!
!
! Last step is to add route first with track optoin
!
route outside 0.0.0.0 0.0.0.0 136.1.0.2 1 track 1
route outside 0.0.0.0 0.0.0.0 136.1.0.3 100
route outside 0.0.0.0 0.0.0.0 136.1.0.2 1 track 1
route outside 0.0.0.0 0.0.0.0 136.1.0.3 100
!
! SLA is first to configure
!
!
sla monitor 1
type echo protocol ipIcmpEcho 150.1.2.2 interface outside
timeout 1000
frequency 1
sla monitor schedule 1 life forever start-time now
no crypto isakmp nat-traversal
!
sla monitor 1
type echo protocol ipIcmpEcho 150.1.2.2 interface outside
timeout 1000
frequency 1
sla monitor schedule 1 life forever start-time now
no crypto isakmp nat-traversal
!
! Second is track where 1 is identfier and second 1 is assocaiting SLA
!
track 1 rtr 1 reachability
!
track 1 rtr 1 reachability
!
!
no crypto isakmp nat-traversal?????
ReplyDeletethat is not required is it?
no crypto isakmp nat-traversal
ReplyDeleteAbove command is not relevant to the topic. Yes you can ignore this command.